Seite 1 von 3 1 2 3 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: ragtek Moderate new users

  1. Kategorie
    Moderation
    Typ
    Add-On
    Version
    1.0.0 RC1
    Lizenz
    Benutzerdefiniert
    Veröffentlicht
    12.02.2009
    Aktualisiert
    24.03.2010
    Downloads
    36
    Installationen
    11
    Bewertung: (3 Stimmen, 5,00 durchschnittlich)
    Kompatible vBulletin-Versionen
    vBulletin 3.6: Alle Versionen
    vBulletin 3.7: Alle Versionen
    vBulletin 3.8: 3.8.0-3.8.4
    vBulletin 4.0: 4.0.0-4.0.2
    Dieses Add-on ermöglicht es, direkt aus der Benachrichtigungsmail heraus, neue Benutzer freizuschalten bzw zu löschen.

    Der Admin, der die Benachrichtungsmail kriegt ( ACP => vB Einstellungen => Benutzer: Registrierung => Benachrichtigung über neue Mitglieder an diese E-Mail-Adresse ) hat dann in der Benachrichtigungsmail 2 Links ( löschen & freischalten).



    Der einzig wirkliche Vorteil von diesem Add-on ist, das man GLEICH nach der Benutzeraktivierung benachrichtigt wird.
    Nicht jeder Admin ist den ganzen Tag über im Forum anwesend und achtet auf solche Details(entweder auf Forumhome bei den "Aktuellen Informationen" oder auf der ACP Startseite.

    Lizenzvereinbarung

    Ihr könnt mit meinen Add-ons machen was ihr wollt.

    Meinen Code als Basis für eigene Add-ons verwenden, Code verändern und als eigenes Add-on verwenden, an beliebige vB Versionen anpassen und unter euren Namen veröffentlichen, das Add-on nehmen und das Klo herunterspielen, einfach alles

    Wäre nett, wenn man mich irgendwo als ursprünglichen Entwickler nennt, ist aber auch kein muss.

    Jetzt herunterladen

    Screenshots

    screenshot.png  

    Unterstützen Sie den Autor

    Geändert von ragtek (24.03.2010 um 20:47 Uhr)
  2. #2
    Registriert seit
    19.12.2008
    Ort
    Wien
    Beiträge
    72
    vBulletin-Version
    3.8.3

    Standard

    Hallo!

    Zuerst mal danke für das nützliche Addon! Hab es mir vorhin installiert. Das löschen des neuen Users per Mail funktioniert perfekt.

    Das Aktivieren funktioniert auch, aber ich (als Admin) bekomme eine weiße Seite mit folgender Fehlermeldung, wenn ich den Link zur Aktivierung des Users klicke:

    Fatal error: Call to undefined function replace_template_variables() in /srv/www/htdocs/fweb30/html/vbb/misc.php(100) : eval()'d code on line 66

    In der misc.php - Zeile 66 ist nur das: 'smiliepopup_row',


    Der User wird aber freigeschalten und kann sich auch nach Klick auf den Link in seiner Mail anmelden.

    Jetzt habe ich ein zweites Mal einen Testuser angemeldet, beim Freischalten wieder obige Fehlermeldung bekommen.
    Danach konnte ich ihn aber problemlos mit dieser Mail wieder löschen.
    Aber - nachdem ich nochmals auf den Aktivierungslink in der Mail geklickt habe, hätte da ja eine Fehlermeldung kommen müssen, weil der User ja schon gelöscht war. Stattdessen bin ich auf der Hilfe Seite "Smiley-Liste" im Board gelandet

    Da spießt sich noch was mit den Smilies.



    LG
    Karin
    Geändert von powersilie (14.02.2009 um 23:33 Uhr)

  3. #3
    Registriert seit
    02.09.2006
    Ort
    Austria (Vienna) , Croatia
    Beiträge
    3.974
    vBulletin-Version
    4.0.7

    Standard

    Hmm, das Add-on benutzt keine replace_template_variables Funktion.

    Das muss von einem anderen Plugin, das auf dem Hook misc_start sitzt, kommen.
    Geändert von ragtek (15.02.2009 um 22:50 Uhr)

  4. #4
    Registriert seit
    19.12.2008
    Ort
    Wien
    Beiträge
    72
    vBulletin-Version
    3.8.3

    Standard

    Hallo!

    So, hab Dein upgedatetes Addon installiert. Genau das gleiche. Es funktioniert im Prinzip einwandfrei.

    Nur hab ich jetzt eine andere Fehlermeldung, wenn ich auf "Aktivieren" klicke:

    Fatal error: Call to undefined function replace_template_variables() in /srv/www/htdocs/fweb30/html/vbb/misc.php(100) : eval()'d code on line 57

    Zeile 57 in der misc.php lautet:'help_bbcodes_link',

    Und genau auf diesen Link komme ich auch immer wieder, wenn ich danach einen der beiden Links in der Mail (für den Admin) anklicke.

    Der neue User ist aber drin, kann sich anmelden, alles bestens.

    LG
    Karin

  5. #5
    Registriert seit
    02.09.2006
    Ort
    Austria (Vienna) , Croatia
    Beiträge
    3.974
    vBulletin-Version
    4.0.7

    Standard

    Du schaust in der falschen Zeile nach

    Die "fehlerhafte" Zeile ist die 100ste und dort wird der Hook ausgeführt, was bedeutet, das ein anderes Plugin am Hook misc-start drann schuld sein muss.

    Du könntest ja dieses Add-on installieren und es damit schneller finden.
    Geändert von ragtek (16.02.2009 um 11:58 Uhr)

  6. #6
    Registriert seit
    19.12.2008
    Ort
    Wien
    Beiträge
    72
    vBulletin-Version
    3.8.3

    Standard

    UUps, danke für den Tipp
    Hab Dein Search-Plugin auch schon eingebaut.

    Blöde Frage: nach welchem Code soll ich denn jetzt suchen?

    LG
    Karin

  7. #7
    Registriert seit
    02.09.2006
    Ort
    Austria (Vienna) , Croatia
    Beiträge
    3.974
    vBulletin-Version
    4.0.7

    Standard

    replace_template_variables
    Aber ja, damit wäre es ja nicht getan*g*, man müsste dann schaun was da genau los ist,...

    Wenn du willst, könnte ich mir das mal anschaun. (Bräuchte dann mal einen Adminzugang(mit Pluginrechten)

  8. #8
    Registriert seit
    19.12.2008
    Ort
    Wien
    Beiträge
    72
    vBulletin-Version
    3.8.3

    Standard

    Wenn ich diesen Code suche, gibt er mir 2x das "ragtek moderate user per mail" Addon aus.

    2x das gleiche:
    ragtek moderate user per mail - misc_start - 5

    LG
    Karin
    Geändert von powersilie (16.02.2009 um 15:49 Uhr)

  9. #9
    Registriert seit
    02.09.2006
    Ort
    Austria (Vienna) , Croatia
    Beiträge
    3.974
    vBulletin-Version
    4.0.7

    Standard

    Ach du heilige Sch****

    Tut mir extrem leid, update kommt gleich.

    Aber eigenartig das ich den Fehler nie hatte.
    Geändert von ragtek (16.02.2009 um 15:51 Uhr)

  10. #10
    Registriert seit
    02.09.2006
    Ort
    Austria (Vienna) , Croatia
    Beiträge
    3.974
    vBulletin-Version
    4.0.7

    Standard

    Ok, müsste jetzt funktionieren.

    Fehler war, das die functions_misc.php bei dir vermutlich nicht aufgerufen wurde, ich konnte das nicht reproduzieren, da die bei mir global geladen wird und dadurch die Funktion vorhanden war.

    Aber ja, hab aus dem Fehler gelernt, ein Testboard sollte komplett leer sein, nichtmal Debugadd-ons sollten vorhanden sein
    Geändert von ragtek (16.02.2009 um 16:37 Uhr)

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •